Human Resources

Human Resources

Home > Apps > Electronic Personnel Action Change (ePAC) Help > System Requirements

System Requirements

Supported Browsers

IE 5.5+
Firefox 1.0.1+
Netscape 6.0+
Mozilla 1.4+
Browser Cookies and JavaScript must be enabled


©